Navigation: Installation >

SQL Express & SSMS

 

 

 

 

Why is my SQL Management Studio (SSMS) not managing to connect to my SQL Express?

 

One of the reasons could be that during the installation of SQL Express, instead of pressing Custom Installation, you chose Basic Installation.
If this is so, you would have missed out on a step during the installation process where you would have had to tick SQL Authentication instead of the default which is Windows Authentication.
But don't worry, there is no need to stay uninstalling and reinstalling them again.

 

First, if needed, change the password of the login user 'sa' by:

Go into SSMS

Logging in with the default windows authentication

Open the security file

Open the logins file

Right-click on the user 'sa'

Click properties

In the General tab, one can change the password

One can also make sure that in the Status tab for the same user, that the login option is enabled

Click OK

 

In order to fix the SQL login issue, one must then:

Go into SSMS

Login with the default database with windows authentication

Once logged in, right-click on the instance (first item in the list)

Select properties

Go in to the security tab

Select 'SQL Server and Windows Authentication Mode'

Click OK

 

Once applied, disconnect from the database and try and login with the default user 'sa' with the SQL authentication.

 

For more information about Installation, please look at the Installation tab in the Scan2x Handbook.

 

 

 

 

 

Copyright © 2022 Avantech Software